Updated gnutls packages that fix multiple security issues are now availablefor Red Hat Enterprise Linux 5.The Red Hat Security Response Team has rated this update as havingImportant security impact. Common Vulnerability Scoring System (CVSS) basescores, which give detailed severity ratings, are available for eachvulnerability from the CVE links in the References section.

The GnuTLS library provides support for cryptographic algorithms and forprotocols such as Transport Layer Security (TLS). The gnutls packages alsoinclude the libtasn1 library, which provides Abstract Syntax Notation One(ASN.1) parsing and structures management, and Distinguished Encoding Rules(DER) encoding and decoding functions.A flaw was found in the way GnuTLS parsed session IDs from ServerHellomessages of the TLS/SSL handshake. A malicious server could use this flawto send an excessively long session ID value, which would trigger a bufferoverflow in a connecting TLS/SSL client application using GnuTLS, causingthe client application to crash or, possibly, execute arbitrary code.(CVE-2014-3466)It was discovered that the asn1_get_bit_der() function of the libtasn1library incorrectly reported the length of ASN.1-encoded data. Speciallycrafted ASN.1 input could cause an application using libtasn1 to performan out-of-bounds access operation, causing the application to crash or,possibly, execute arbitrary code. (CVE-2014-3468)Multiple incorrect buffer boundary check issues were discovered inlibtasn1. Specially crafted ASN.1 input could cause an application usinglibtasn1 to crash. (CVE-2014-3467)Multiple NULL pointer dereference flaws were found in libtasn1’sasn1_read_value() function. Specially crafted ASN.1 input could cause anapplication using libtasn1 to crash, if the application used theaforementioned function in a certain way. (CVE-2014-3469)Red Hat would like to thank GnuTLS upstream for reporting these issues.Upstream acknowledges Joonas Kuorilehto of Codenomicon as the originalreporter of CVE-2014-3466.Users of GnuTLS are advised to upgrade to these updated packages, whichcorrect these issues. For the update to take effect, all applicationslinked to the GnuTLS or libtasn1 library must be restarted.
Before applying this update, make sure all previously released erratarelevant to your system have been applied.This update is available via the Red Hat Network. Details on how to use theRed Hat Network to apply this update are available athttps://access.redhat.com/site/articles/11258RHEL Desktop Workstation (v. 5 client)

SRPMS:
gnutls-1.4.1-16.el5_10.src.rpm
    MD5: 9276ec80d47e4533a642e28491349b89SHA-256: 7116df5683ce671aa5a3450917e0a1e01f886d7e3361d22202ceb68fa6dc1874
 
IA-32:
gnutls-debuginfo-1.4.1-16.el5_10.i386.rpm
    MD5: 5bc0201f80efc469ec6cb3a3909ee7d6SHA-256: 2d397670e05f789910ce8ed7fce3eb34122f874ce045bce74991670090c2e357
gnutls-devel-1.4.1-16.el5_10.i386.rpm
    MD5: f4539fb890a61d119d306d37b461a6c8SHA-256: 9fae428aa3516c29e670c6d503d5d0adac28d67bfc6f1cda39515a06923bd58e
 
x86_64:
gnutls-debuginfo-1.4.1-16.el5_10.i386.rpm
    MD5: 5bc0201f80efc469ec6cb3a3909ee7d6SHA-256: 2d397670e05f789910ce8ed7fce3eb34122f874ce045bce74991670090c2e357
gnutls-debuginfo-1.4.1-16.el5_10.x86_64.rpm
    MD5: bd201c17298e8a2da6ec37d32a35475eSHA-256: 16760c393aac3ee0f41ec274964597ac7920e7fe1fa15ca31403b70c0326f114
gnutls-devel-1.4.1-16.el5_10.i386.rpm
    MD5: f4539fb890a61d119d306d37b461a6c8SHA-256: 9fae428aa3516c29e670c6d503d5d0adac28d67bfc6f1cda39515a06923bd58e
gnutls-devel-1.4.1-16.el5_10.x86_64.rpm
    MD5: 030fbe509e42011362b854c13d4415ecSHA-256: 1b2263e49f0c7d6dfc1c811d79629fb37f89d4f9084b0ba8bfe6d61e2c19e8b8
 
Red Hat Enterprise Linux (v. 5 server)

SRPMS:
gnutls-1.4.1-16.el5_10.src.rpm
    MD5: 9276ec80d47e4533a642e28491349b89SHA-256: 7116df5683ce671aa5a3450917e0a1e01f886d7e3361d22202ceb68fa6dc1874
 
IA-32:
gnutls-1.4.1-16.el5_10.i386.rpm
    MD5: 599f420a8a95a10595b4c2e038b4bb30SHA-256: fd557097d2b151a651bdc57debed14d20f93ce8e4fa8950ae0983c2a95edf833
gnutls-debuginfo-1.4.1-16.el5_10.i386.rpm
    MD5: 5bc0201f80efc469ec6cb3a3909ee7d6SHA-256: 2d397670e05f789910ce8ed7fce3eb34122f874ce045bce74991670090c2e357
gnutls-devel-1.4.1-16.el5_10.i386.rpm
    MD5: f4539fb890a61d119d306d37b461a6c8SHA-256: 9fae428aa3516c29e670c6d503d5d0adac28d67bfc6f1cda39515a06923bd58e
gnutls-utils-1.4.1-16.el5_10.i386.rpm
    MD5: c85ad8966af21e04e81a0cfca8f285ffSHA-256: 1821c31a23df55e604709326fbe3e199e4e5888becf338f0998052e8456eff3b
 
IA-64:
gnutls-1.4.1-16.el5_10.i386.rpm
    MD5: 599f420a8a95a10595b4c2e038b4bb30SHA-256: fd557097d2b151a651bdc57debed14d20f93ce8e4fa8950ae0983c2a95edf833
gnutls-1.4.1-16.el5_10.ia64.rpm
    MD5: 98ebafc4a007ae01f2f7f6422db22fb1SHA-256: 649e5dcde140e0b75d8919e84493197c8d12cf07bb452e48cff276c3dcab990b
gnutls-debuginfo-1.4.1-16.el5_10.i386.rpm
    MD5: 5bc0201f80efc469ec6cb3a3909ee7d6SHA-256: 2d397670e05f789910ce8ed7fce3eb34122f874ce045bce74991670090c2e357
gnutls-debuginfo-1.4.1-16.el5_10.ia64.rpm
    MD5: 748e2c05587dc54c9a087c704084b952SHA-256: 720175fab6ac97fb650d211c4f7a6d7619c34ba1acd29fd90a8c3359e5e66253
gnutls-devel-1.4.1-16.el5_10.ia64.rpm
    MD5: 1de97aa0b2dd39e1ee1f91b9dfba4cb7SHA-256: 221df6500931cbca7f518aa3e4ca61b441de3c3da0270281ddb041ea21a62c30
gnutls-utils-1.4.1-16.el5_10.ia64.rpm
    MD5: d00c03ab73a5c5db995238e3e564908dSHA-256: 8bb0ae93a42dd9dc75e8271059295b7540d9da864ef77b7a3c795f992c84fba9
 
PPC:
gnutls-1.4.1-16.el5_10.ppc.rpm
    MD5: 63613870872985eb86c118ca36e705f9SHA-256: ec84b5ec07145ae291755a2971b75ea8d8a3dcaa12b960c4d1b07fc10278b655
gnutls-1.4.1-16.el5_10.ppc64.rpm
    MD5: 8bc7b471798fa89764835910b9b35b8dSHA-256: 9dbabb76bdb50a70e65e44d48eb76c9b090ec66ae0764a7cae86fccd194ce224
gnutls-debuginfo-1.4.1-16.el5_10.ppc.rpm
    MD5: 7ddfd3edc25c4210cb07fa0e453f93f7SHA-256: 78cebe828f7838d304b4e329732f5a80885cad24d615cd1b2fe92e16ac85897b
gnutls-debuginfo-1.4.1-16.el5_10.ppc64.rpm
    MD5: 1126e3e62704cb01874c14df6bb3a8e0SHA-256: 7792739a4589d9de7d3c33e2551f2a99921d18741a9e225f465f0a44321b9869
gnutls-devel-1.4.1-16.el5_10.ppc.rpm
    MD5: 4d0598c9c14b2d290837c60424323e53SHA-256: c75ad104a02bd12936fe3788767e5d0063b905b409421632daac280389784290
gnutls-devel-1.4.1-16.el5_10.ppc64.rpm
    MD5: 8e50f6eece160ee64dbb505f221777c6SHA-256: ca2c3d9c83104525e7757abb9050187badecbe084fb33c566ce7edc6144b6647
gnutls-utils-1.4.1-16.el5_10.ppc.rpm
    MD5: e89f365ac8ec76de323868bf32fd1609SHA-256: d41b5a4fb18aba2ac94d38d11b008173c9bccea3946da7c3926a2ff609f6f53f
 
s390x:
gnutls-1.4.1-16.el5_10.s390.rpm
    MD5: 4477287c53b9d765d600688421a80ccdSHA-256: c9a501cfec6c13b1cd1647c85a41738c7257f7b4ed5870dc29efeb10da489712
gnutls-1.4.1-16.el5_10.s390x.rpm
    MD5: 60838066b52e1b179f832ddb1aca6824SHA-256: aded7f067dbe233671eb9db41543a0eb7b6b11180d1ee50d5aef031f3915f7c4
gnutls-debuginfo-1.4.1-16.el5_10.s390.rpm
    MD5: 70c1bd0352362cb0cdf93cc87eb0e883SHA-256: 59d7332743871907c179d5d15b34d5a3ddc22fc4512b033f075a2d6bcae11b42
gnutls-debuginfo-1.4.1-16.el5_10.s390x.rpm
    MD5: 29ba3efd7fd6d11120437b05093178c5SHA-256: 96e0b9e6b4d27acb00cb4e87c6256c2d9a2bbf793ee3b212736b1f5fbc317815
gnutls-devel-1.4.1-16.el5_10.s390.rpm
    MD5: 7908ab4d096e498075621fe1f1d07bd5SHA-256: 308360d66f9e61b851b35cdc784ecc94296ca28541b3109a65af260258aa879d
gnutls-devel-1.4.1-16.el5_10.s390x.rpm
    MD5: 269268f042098455a3c2cd1d8be2509cSHA-256: aee7aee4050afd2eb3e180ccedd407c140106f11c93f514801237a2ac617062e
gnutls-utils-1.4.1-16.el5_10.s390x.rpm
    MD5: 332e57b931832ad5c7d6394b753a4e43SHA-256: 866e781b889099ca55ff52c76c54e2564f576b2cee7bab6a22d296a92a9d086c
 
x86_64:
gnutls-1.4.1-16.el5_10.i386.rpm
    MD5: 599f420a8a95a10595b4c2e038b4bb30SHA-256: fd557097d2b151a651bdc57debed14d20f93ce8e4fa8950ae0983c2a95edf833
gnutls-1.4.1-16.el5_10.x86_64.rpm
    MD5: 0f3e4bc866deca4e503679fa9fbc92baSHA-256: 4f6d29615b6e20567a601d1cbbf4ec1e2d43dbb8fb38af22bb4119c6a5c866a1
gnutls-debuginfo-1.4.1-16.el5_10.i386.rpm
    MD5: 5bc0201f80efc469ec6cb3a3909ee7d6SHA-256: 2d397670e05f789910ce8ed7fce3eb34122f874ce045bce74991670090c2e357
gnutls-debuginfo-1.4.1-16.el5_10.x86_64.rpm
    MD5: bd201c17298e8a2da6ec37d32a35475eSHA-256: 16760c393aac3ee0f41ec274964597ac7920e7fe1fa15ca31403b70c0326f114
gnutls-devel-1.4.1-16.el5_10.i386.rpm
    MD5: f4539fb890a61d119d306d37b461a6c8SHA-256: 9fae428aa3516c29e670c6d503d5d0adac28d67bfc6f1cda39515a06923bd58e
gnutls-devel-1.4.1-16.el5_10.x86_64.rpm
    MD5: 030fbe509e42011362b854c13d4415ecSHA-256: 1b2263e49f0c7d6dfc1c811d79629fb37f89d4f9084b0ba8bfe6d61e2c19e8b8
gnutls-utils-1.4.1-16.el5_10.x86_64.rpm
    MD5: 7b1a09957c03d913ae3cb22fbebd2ac1SHA-256: 28a9e843e61032727636074ff3486a87780f625d1880c4b1aa2eeb4d0cf13a0b
 
Red Hat Enterprise Linux Desktop (v. 5 client)

SRPMS:
gnutls-1.4.1-16.el5_10.src.rpm
    MD5: 9276ec80d47e4533a642e28491349b89SHA-256: 7116df5683ce671aa5a3450917e0a1e01f886d7e3361d22202ceb68fa6dc1874
 
IA-32:
gnutls-1.4.1-16.el5_10.i386.rpm
    MD5: 599f420a8a95a10595b4c2e038b4bb30SHA-256: fd557097d2b151a651bdc57debed14d20f93ce8e4fa8950ae0983c2a95edf833
gnutls-debuginfo-1.4.1-16.el5_10.i386.rpm
    MD5: 5bc0201f80efc469ec6cb3a3909ee7d6SHA-256: 2d397670e05f789910ce8ed7fce3eb34122f874ce045bce74991670090c2e357
gnutls-utils-1.4.1-16.el5_10.i386.rpm
    MD5: c85ad8966af21e04e81a0cfca8f285ffSHA-256: 1821c31a23df55e604709326fbe3e199e4e5888becf338f0998052e8456eff3b
 
x86_64:
gnutls-1.4.1-16.el5_10.i386.rpm
    MD5: 599f420a8a95a10595b4c2e038b4bb30SHA-256: fd557097d2b151a651bdc57debed14d20f93ce8e4fa8950ae0983c2a95edf833
gnutls-1.4.1-16.el5_10.x86_64.rpm
    MD5: 0f3e4bc866deca4e503679fa9fbc92baSHA-256: 4f6d29615b6e20567a601d1cbbf4ec1e2d43dbb8fb38af22bb4119c6a5c866a1
gnutls-debuginfo-1.4.1-16.el5_10.i386.rpm
    MD5: 5bc0201f80efc469ec6cb3a3909ee7d6SHA-256: 2d397670e05f789910ce8ed7fce3eb34122f874ce045bce74991670090c2e357
gnutls-debuginfo-1.4.1-16.el5_10.x86_64.rpm
    MD5: bd201c17298e8a2da6ec37d32a35475eSHA-256: 16760c393aac3ee0f41ec274964597ac7920e7fe1fa15ca31403b70c0326f114
gnutls-utils-1.4.1-16.el5_10.x86_64.rpm
    MD5: 7b1a09957c03d913ae3cb22fbebd2ac1SHA-256: 28a9e843e61032727636074ff3486a87780f625d1880c4b1aa2eeb4d0cf13a0b
 
(The unlinked packages above are only available from the Red Hat Network)
1101932 – CVE-2014-3466 gnutls: insufficient session id length check in _gnutls_read_server_hello (GNUTLS-SA-2014-3)1102022 – CVE-2014-3467 libtasn1: multiple boundary check issues1102323 – CVE-2014-3468 libtasn1: asn1_get_bit_der() can return negative bit length1102329 – CVE-2014-3469 libtasn1: asn1_read_value_type() NULL pointer dereference

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from:

Leave a Reply