Red Hat OpenShift Enterprise release 1.2.8 is now available with updates topackages that fix several bugs and introduce a feature enhancement. This updateadds necessary support for software dependencies that will change with theupcoming release of Red Hat Software Collections (SCL) version 1.1.

OpenShift Enterprise by Red Hat is the company’s cloud computingPlatform-as-a-Service (PaaS) solution designed for on-premise or private clouddeployments.This update fixes the following bugs:* When using unauthenticated DNS updates, the oo-accept-broker andoo-register-dns commands would fail, even though the dns-nsupdate plug-inalready supported unauthenticated DNS. This bug fix updates the logic for bothcommands to support unauthenticated DNS, and these commands no longer fail as aresult. (BZ#1007700)* SSH keys with the name “.” or “..” were misinterpreted by the REST API, and asa result these keys could not be deleted. To avoid these deletion issues, thisbug fix updates the SSH key validation to prevent the addition of keys withnames beginning with “.”. (BZ#1018642)* After installing a custom or community cartridge using the oo-admin-cartridgecommand and clearing the broker cache, the oo-accept-systems command reportedinconsistent cartridge lists between the broker and nodes. This was due to thenew cartridge receiving a problematic SELinux context during its installationinto the cartridge repository. This bug fix ensures that cartridges installedusing oo-admin-cartridge are relabeled using the default contexts, andoo-accept-systems no longer reports inconsistent cartridge lists. (BZ#1053029)This update also adds the following enhancement:* This update adds necessary support for software dependencies that will changewith the upcoming release of Red Hat Software Collections (SCL) version 1.1 byupdating several OpenShift Enterprise components. (BZ#1093808)All users of OpenShift Enterprise 1.2 are advised to upgrade to these updatedpackages.
Before applying this update, make sure all previously released errata relevantto your system have been applied.This update is available via the Red Hat Network. Details on how to use the RedHat Network to apply this update are available athttps://access.redhat.com/site/articles/11258.After running the yum update command on each host and ensuring all packages havebeen updated, restart the mcollective service on each node host:# service mcollective restartOn the broker host, restart the broker service and, if installed, the consoleservice:# service openshift-broker restart# service openshift-console restartClear the broker cache and, if installed, the console cache:# oo-admin-broker-cache –consoleRed Hat OpenShift Enterprise 1

SRPMS:
openshift-enterprise-upgrade-1.2.7.1-1.el6op.src.rpm
    MD5: ac9bffdebd50ca64f03b6b0ed108baa9SHA-256: d3345a2be7094cee6bf0f88b7b4baaeb4f1db0ef8420d49d24b5b679dbc63843
openshift-origin-broker-1.5.10.1-1.el6op.src.rpm
    MD5: f745c1421676d3e8faadaed404b12dcdSHA-256: 54e9fe317925cbc7eb25f6b59f7cc5bea0132b1013bd79039399a0bb19fd70c1
openshift-origin-broker-util-1.9.17.1-1.el6op.src.rpm
    MD5: b9f515dd10bc090a6e7cf383437aa3a2SHA-256: 1eed9b6967c52620d63a8b7be6cb3040ef1a87f786c2682cb516b9d4403e203e
openshift-origin-cartridge-ruby-0.4.10.5-1.el6op.src.rpm
    MD5: 395e8362172a6847e161248d7b600b9bSHA-256: 6c266ce200520963177c8cb2bb8065f9482692d2ff41ba5a20a7120d1f93b121
openshift-origin-console-1.5.25.1-1.el6op.src.rpm
    MD5: 32135311569ea2fbd1b136b82c5fb952SHA-256: 4f6ed914002264f81756b98f4f2dd50bbf2461e9077b1b233953f78fc0fe7278
openshift-origin-util-scl-1.4.1.2-1.el6op.src.rpm
    MD5: 162f4fed1c1374a268baebf0a024c8a3SHA-256: af9d66dfc706f77aaece7abff115ea70c0f69bec5aa588905512900bd8a6e1e3
rubygem-openshift-origin-common-1.8.18.1-1.el6op.src.rpm
    MD5: 70f71a09a7c1550abf9437843b28997fSHA-256: 04666b44fca023f146e36ee1e25a2277a95becef6af8be82768b83c627b50de7
rubygem-openshift-origin-controller-1.9.16.3-1.el6op.src.rpm
    MD5: 1e9b395079e33586814a867ce573aae5SHA-256: 3c29c31a7d2339926623d8845ed4239ad38408f71aec8e2da586cfcc16e77727
rubygem-openshift-origin-node-1.9.14.7-1.el6op.src.rpm
    MD5: 1a3f6dae18183a722919c2187ba3b656SHA-256: 2004121cf4a7b79e961ffe21205b5a9a05403255ddec4b2f71716264014702e8
 
x86_64:
openshift-enterprise-release-1.2.7.1-1.el6op.noarch.rpm
    MD5: d919e738315f3a185116840fceddac82SHA-256: 98b41293bd2096026bd5ce1643b811bec7356a036eb4de5bdc57ded8ad8f694c
openshift-enterprise-upgrade-broker-1.2.7.1-1.el6op.noarch.rpm
    MD5: 9834fd24c81ea30196a294a08fc9acefSHA-256: 1331fcb12df7427f0eaf71efccc19a639835dbbbf15966783025eb6013bd10ea
openshift-enterprise-upgrade-node-1.2.7.1-1.el6op.noarch.rpm
    MD5: f3e1ec1860edc32499c58001679e8400SHA-256: 5c38570f33586a32abf6c8da473a20eca0e161ce313b4939c55f63ae4bd62eed
openshift-enterprise-yum-validator-1.2.7.1-1.el6op.noarch.rpm
    MD5: 74b2c0bbaeb8b171d0f765b855ac16bcSHA-256: a07376508cb4712a06d5e2713bc4cdf1389e7a72f0d7c68ea2fd690008de4400
openshift-origin-broker-1.5.10.1-1.el6op.noarch.rpm
    MD5: 8b4290674e96b7fb08d2b624e41c0111SHA-256: 3e5face06210b2c5cdc23060a1a6ee44339429bc30e99e09f540afabe143f06b
openshift-origin-broker-util-1.9.17.1-1.el6op.noarch.rpm
    MD5: 60e879406a316e82d1a00844840b90f3SHA-256: e60cb31c877ec36d2d524c4bd55479e31e4706cba5fa77a16ee7637ccccff7f5
openshift-origin-cartridge-ruby-0.4.10.5-1.el6op.noarch.rpm
    MD5: f61d463b46aa2dad38f58cbb199e41b8SHA-256: 58fc47a071981d23ec336b094d88315c635f1a1611a3f47d41dd34dd935f2b8d
openshift-origin-console-1.5.25.1-1.el6op.noarch.rpm
    MD5: c67b7a40ce863e7e1e950f71fca0b5cfSHA-256: b4b45806deb5813b1e5180b718477dd245c238a8dc4cbe476972bfc64690b684
openshift-origin-util-scl-1.4.1.2-1.el6op.noarch.rpm
    MD5: 58e98f2884f3044eafddef79af819d96SHA-256: b524f18a29f7be6cad97433b8413480a79ed5a26ef74dce470151e922644b4be
rubygem-openshift-origin-common-1.8.18.1-1.el6op.noarch.rpm
    MD5: 0d4a52fd56eedf58f934f3e4d9f0cb0aSHA-256: efae019fb01e1a88c5c119318fc89dd956ce376701cdbfd8fc93ddad1ef08f67
rubygem-openshift-origin-controller-1.9.16.3-1.el6op.noarch.rpm
    MD5: accac5d401c96292002675f50558594fSHA-256: aac2e491e484e62f531478450904f230e40007be42ece2549ffc43b3368f28a1
rubygem-openshift-origin-node-1.9.14.7-1.el6op.noarch.rpm
    MD5: 2fc1b6e5491a1fa768394a72390fc7d3SHA-256: 00170bf61138617a85c48645761f01e98c8e7ce2305db331df86e95f41ab78fe
 
(The unlinked packages above are only available from the Red Hat Network)
1007700 – oo-accept-broker and oo-register-dns will fail when using unauthenticated DNS updates1018642 – Failed to delete the ssh key with name “.”1093808 – LD_LIBRARY_PATH updates required for v8 collection change

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from:

Leave a Reply