Updated postgresql92 packages that fix several bugs are now available for RedHat Software Collections 1.1 for Red Hat Enterprise Linux.

PostgreSQL is an advanced object-relational database management system (DBMS).The postgresql92 packages have been upgraded to upstream version 9.2.8, whichprovides a number of bug fixes over the previous version. (BZ#1079994)This update also fixes the following bug:* Previously, not all files in an RPM package were correctly owned by thecorresponding collection. As a consequence, when the postgresql92 collection wasremoved, some files remained in the /opt/rh/postgresql92/root/ directory. Withthis update, all files in the postgresql92 collection are owned properly and noredundant files are left after the collection is removed. (BZ#1079968)Users of postgresql92 are advised to upgrade to these updated packages, whichfix these bugs.
Before applying this update, make sure all previously released erratarelevant to your system have been applied.This update is available via the Red Hat Network. Details on how touse the Red Hat Network to apply this update are available athttps://access.redhat.com/site/articles/11258Red Hat Software Collections 1 for RHEL 6

SRPMS:
postgresql92-1.1-20.el6.src.rpm
    MD5: 479f5c6232f9f36b716b54841438a16dSHA-256: ea326d0b3df1ba3a641994ea14d2cbfc3096519058a25fad84613e7c0a0938a1
postgresql92-postgresql-9.2.8-1.el6.src.rpm
    MD5: 2cd0a856ca0236785226a54f81a01230SHA-256: 65432a1ae309a03c10930a32ffc6e1dd844089994de4a97e0d35d45b85589ac4
 
x86_64:
postgresql92-1.1-20.el6.x86_64.rpm
    MD5: ee4c33c372eb2704866aebcd6164cd89SHA-256: 976bb830857c6850be6320adff07b0a0a96e21717f86a5e1f49fd113a722f268
postgresql92-postgresql-9.2.8-1.el6.x86_64.rpm
    MD5: e8ecfa734b7905d8adbdc4b6a2da6502SHA-256: 83e359cc9a635e01e946d1170ea72caa1aa3425c9af6a3f18fae78a57e8aee8b
postgresql92-postgresql-contrib-9.2.8-1.el6.x86_64.rpm
    MD5: 08696e0ecd75c1a182605a1ec29c8a01SHA-256: ea6458362f09e62151f1fbf50069552aee1ae34c80015e0b98b4cf18cce530d9
postgresql92-postgresql-debuginfo-9.2.8-1.el6.x86_64.rpm
    MD5: e592a6bf8ea71cd1d09984ea1b366683SHA-256: b0f4b350dee9363a25e8fab9fa7f1a922df94dbe1b300c411dc20e6f747e2480
postgresql92-postgresql-devel-9.2.8-1.el6.x86_64.rpm
    MD5: 1c7a202d0493b25d27dbf75ec8b5a317SHA-256: c1c8775e6c50cbc208bcf1905853b29aa1c1ac6c6a4f74e4ad05d62dc870d343
postgresql92-postgresql-docs-9.2.8-1.el6.x86_64.rpm
    MD5: c68596eeed6f438d1b3936b434221134SHA-256: eaa20043b2dfe7458020be6dd2f85254b574a92043db3b9327ec2401c9ce3433
postgresql92-postgresql-libs-9.2.8-1.el6.x86_64.rpm
    MD5: 5dbd87ca6be29361a9372a2c34dfd8a8SHA-256: 5f0cddfdd5c116c1adb965dab1aeb91cc8b465f7ff05adb8527602c098d97178
postgresql92-postgresql-plperl-9.2.8-1.el6.x86_64.rpm
    MD5: 9cfa9cb11ebfdff1496e93fc9806f807SHA-256: 3310f5247529217b4fd2d8ae28880c709f9dba7fca12108e8b654f1dbe1e8d9b
postgresql92-postgresql-plpython-9.2.8-1.el6.x86_64.rpm
    MD5: d64e21fe4a5edce88c4110aebcb871b1SHA-256: 4db76d01ce0b586e99cf1e26db578459d0c38497c93efb3ad44a268ad5af10cf
postgresql92-postgresql-pltcl-9.2.8-1.el6.x86_64.rpm
    MD5: 1e4d2a868da59ba6f74df57dcd35f6a9SHA-256: 73698b835b51813b08dd9a3ba6097b7925dcf86b9e582467114f1c2e68fa7b14
postgresql92-postgresql-server-9.2.8-1.el6.x86_64.rpm
    MD5: 17403a6d21537a520eef332d6d577e84SHA-256: 709f48f57bf0030c82cf43d8711f5d1a9c717701b8ac13063059c66fc657d41c
postgresql92-postgresql-test-9.2.8-1.el6.x86_64.rpm
    MD5: 13cd786daf807e51ca7b42cfccd105dbSHA-256: d8bcfd01eda1abaecbd888220123bb9e096197bda24285da64b6b16d99252d9e
postgresql92-postgresql-upgrade-9.2.8-1.el6.x86_64.rpm
    MD5: b28b1d265fe49bb3cd0d0eb1e2bcb60dSHA-256: 38b5462afddf2dca0e25f86a914a3a02be3ded5a78c6757e029c1a8e6f89e111
postgresql92-runtime-1.1-20.el6.x86_64.rpm
    MD5: 7370e37aad5208a001809e876d13c18fSHA-256: 5d1270c79921918d56817624814c97fe8db10d51ed5f8aed911dd6bf38c281d1
postgresql92-scldevel-1.1-20.el6.x86_64.rpm
    MD5: 57359f12cabab89f6346148df2785f73SHA-256: 3860bf3e3291d82c5d63833e1800aa757bf8f9226144e71f1d88d411c9327899
 
(The unlinked packages above are only available from the Red Hat Network)
1009365 – incorrect PGDATA path in /opt/rh/postgresql92/root/var/lib/pgsql/.bash_profile1060767 – legacy action scripts initdb and upgrade should use scl environment settings1061456 – postgresql92 meta package should include LICENSE, README and postgresql92 man page files1079994 – rebase postgresql to 9.2.8

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from:

Leave a Reply