Vulnerability Note VU#573356
IBM WebSphere Application Server contains multiple vulnerabilities
Original Release date: 08 Oct 2014 | Last revised: 16 Oct 2014

Overview
IBM WebSphere Application Server, including the Hypervisor Edition, contains cross-site scripting and cross-site request forgery vulnerabilities.

Description
CWE-79: Improper Neutralization of Input During Web Page Generation (‘Cross-site Scripting’) – CVE-2014-4770
IBM WebSphere Application Server, including the Hypervisor Edition, contains a cross-site scripting (XSS) vulnerability in the Administrative Console.

CWE-352: Cross-Site Request Forgery (CSRF) – CVE-2014-4816
IBM WebSphere Application Server, including the Hypervisor Edition, contains a cross-site request forgery (CSRF) vulnerability in the Administrative Console. The application also provides a URL that allows authenticated users to directly create and modify their session variables ("Session Injection"), including CSRF tokens.

IBM reports that the following versions are affected:

Version 8.5
Version 8
Version 7
Version 6.1
Version 6.0.2

The CVSS score reflects CVE-2014-4770.

Impact
A remote unauthenticated attacker may be able to execute arbitrary script in the context of the end-user’s browser session. Additionally, a remote unauthenticated attacker may be able to trick an authenticated user into making an unintentional request to the web server which will be treated as an authentic request and may result in information leakage or modification.

Solution
IBM provides the following remediation guidance in their security bulletin:

The recommended solution is to apply the Interim Fix, Fix Pack or PTF for each named product as soon as practical.

Fix: Apply an Interim Fix, Fix Pack or PTF containing APAR PI23055, as noted below:
For affected IBM WebSphere Application Server:

For V8.5.0.0 through 8.5.5.3:
Apply Fix Pack 8.5.5.0 or later
Then apply Interim Fix PI23055
–OR–
Apply Fix Pack 8.5.5.4 or later (targeted to be available 8 December 2014).

For V8.0.0.0 through 8.0.0.9:
Apply Fix Pack 8.0.0.6 or later
Then apply interim Fix PI23055
–OR–
Apply Fix Pack 8.0.0.10 or later (targeted to be available 16 February 2015).

For V7.0.0.0 through 7.0.0.31:
Apply Fix Pack 7.0.0.27 or later
Then apply Interim Fix PI23055
–OR–
Apply Fix Pack 7.0.0.35 or later (targeted to be available 13 October 2014).

For V6.1.0.0 through 6.1.0.47:
Apply Fix Pack 6.1.0.47 and then apply Interim Fix PI23055

Vendor Information (Learn More)

VendorStatusDate NotifiedDate UpdatedIBM CorporationAffected18 Jul 201402 Oct 2014If you are a vendor and your product is affected, let
us know.

CVSS Metrics (Learn More)

Group
Score
Vector

Base
4.9
AV:N/AC:M/Au:S/C:P/I:P/A:N

Temporal
3.8
E:POC/RL:OF/RC:C

Environmental
3.9
CDP:ND/TD:ND/CR:ND/IR:ND/AR:ND

References

http://www-01.ibm.com/support/docview.wss?uid=swg21682767
http://cwe.mitre.org/data/definitions/79.html
http://cwe.mitre.org/data/definitions/352.html

Credit

Thanks to Łukasz Płonka for reporting this vulnerability.
This document was written by Todd Lewellen.

Other Information

CVE IDs:
CVE-2014-4770
CVE-2014-4816

Date Public:
18 Sep 2014

Date First Published:
08 Oct 2014

Date Last Updated:
16 Oct 2014

Document Revision:
28

FeedbackIf you have feedback, comments, or additional information about this vulnerability, please send us email.

Leave a Reply