Red Hat OpenShift Enterprise release 2.1.10 is now available with updates topackages that fix two bugs.

OpenShift Enterprise by Red Hat is the company’s cloud computingPlatform-as-a-Service (PaaS) solution designed for on-premise or private clouddeployments.* The subscription-manager package version 1.10.7 and higher now incorporatesthe “content override” feature, which typically requires network communicationwith a back-end server. As a result, certain oo-admin-yum-validator functionsrelated to subscription-manager, which had previously only operated on the localfile system in older subscription-manager versions, could now raise unhandledexceptions due to network failures. This bug fix wraps routines depending onsubscription-manager in exception-handling blocks, and scripts which depend onthe oo-admin-yum-validator command can now detect that it failed due to networkerrors. Administrators are now presented with a relevant error message insteadof a confusing stack trace. (BZ#1166276)* The Ruby Bundler for ruby18 applications was out of date and had compatibilityissues with rubygems.org. This issue caused ruby18 applications that used’bundle install’ to take prohibitively long to deploy. This bug fix updates RubyBundler, and as a result ‘bundle install’ now completes in a timely manner.(BZ#1171747)All OpenShift Enterprise users are advised to upgrade to these updated packages.
Before applying this update, make sure all previously released errata relevantto your system have been applied.This update is available via the Red Hat Network. Details on how to use the RedHat Network to apply this update are available athttps://access.redhat.com/articles/11258.Red Hat OpenShift Enterprise 2

SRPMS:
openshift-enterprise-upgrade-2.1.10-1.el6op.src.rpm
    MD5: 836837e0cc945acb2eeea1e853911cd9SHA-256: 3e8c455ab743ebd715dd7d719230cce430e450a66e60fce735dae79282d280cb
rubygem-bundler-1.3.5-4.el6op.src.rpm
    MD5: 2cf76ada97cb711ab16ccdaf353758eaSHA-256: 4d3ecdf838bdc3f909083015c8f54bd5c0f0209e3ca15d9a5e4499e5b868567a
rubygem-net-http-persistent-2.3.2-4.el6op.src.rpm
    MD5: 5f2fa2a9338dee53ce1302458e5b2612SHA-256: bf362adf4aaefa7a779142f45fefcc99c67d96002fa4393e9362f90939c440ff
rubygem-thor-0.18.1-2.el6op.src.rpm
    MD5: a52caba1950fa5f42d7bed2021fbf0d0SHA-256: bb6b2078a29722f0a4777711b3bb3e8601db7043b2acdfa62519c1204d4a396b
 
x86_64:
openshift-enterprise-release-2.1.10-1.el6op.noarch.rpm
    MD5: 0564d44a47294c171ac0d272562a94e2SHA-256: c9e7ef49a59fa1bb3b46115d192369c7654816c120cfa7f54a277a625593567a
openshift-enterprise-upgrade-broker-2.1.10-1.el6op.noarch.rpm
    MD5: 80a1c2db35741eb7bd844ec8fc68949cSHA-256: b0ddd82152d0ffc4c58c44f5999675ff87f7c17e8bda30ce462ba4e1a93f4cbf
openshift-enterprise-upgrade-node-2.1.10-1.el6op.noarch.rpm
    MD5: 7994e9e087aae329580bd507ae2f9ff4SHA-256: 2216f6dcc41aa801f0bc0546d6d2511c1fc0297c074fe76c4eb43bf3bbc26c37
openshift-enterprise-yum-validator-2.1.10-1.el6op.noarch.rpm
    MD5: 8ced9a9852f2f4504acb89089ef5de70SHA-256: 5ce78acbeaeb2c21ffc952cbc08996fb015f91e6d9bc4e0189978a52964dbd39
rubygem-bundler-1.3.5-4.el6op.noarch.rpm
    MD5: 7001dbb828f3ea5f9f401ac27e9e6497SHA-256: c11a185786e8d2d4ede9f28e685afb04ed2a7e5c358c25b89153f9af04f819f0
rubygem-net-http-persistent-2.3.2-4.el6op.noarch.rpm
    MD5: 3c15e5d48c44c6321e9c8f2bab2c3760SHA-256: 21193e97832420457f178a480fcf919150189de6a9e434b9e0bbbec680716a54
rubygem-net-http-persistent-doc-2.3.2-4.el6op.noarch.rpm
    MD5: dfc0dabc1580a2e1bac14d5c2336e986SHA-256: c8824a23f310636cbcec563101340c0fda43abdff712cb4e8566037f1a4996fc
rubygem-thor-0.18.1-2.el6op.noarch.rpm
    MD5: 76a017acde9f8c320a951bdef319d045SHA-256: 2a2de30dc5e0f200a55cfa5f7987a11938343bf338c7662be9c8bde27c55fa00
 
(The unlinked packages above are only available from the Red Hat Network)
1166276 – OSE 2.1: oo-admin-yum-validator doesn’t handle error code from failed subscription-manager repo-override calls1171747 – It takes a very long time to run ‘bundle install’ in ruby-1.8 app compare with ruby-1.9

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from:

Leave a Reply