Updated libvncserver packages that fix two security issues are nowavailable for Red Hat Enterprise Linux 6.5 Extended Update Support.Red Hat Product Security has rated this update as having Moderate securityimpact. Common Vulnerability Scoring System (CVSS) base scores, which givedetailed severity ratings, are available for each vulnerability from theCVE links in the References section.

LibVNCServer is a library that allows for easy creation of VNC server orclient functionality.An integer overflow flaw, leading to a heap-based buffer overflow, wasfound in the way screen sizes were handled by LibVNCServer. A malicious VNCserver could use this flaw to cause a client to crash or, potentially,execute arbitrary code in the client. (CVE-2014-6051)Two stack-based buffer overflow flaws were found in the way LibVNCServerhandled file transfers. A remote attacker could use this flaw to crash theVNC server using a malicious VNC client. (CVE-2014-6055)Red Hat would like to thank oCERT for reporting these issues. oCERTacknowledges Nicolas Ruff as the original reporter.All libvncserver users are advised to upgrade to these updated packages,which contain backported patches to correct these issues. All runningapplications linked against libvncserver must be restarted for this updateto take effect.
Before applying this update, make sure all previously released erratarelevant to your system have been applied.This update is available via the Red Hat Network. Details on how to use theRed Hat Network to apply this update are available athttps://access.redhat.com/articles/11258Red Hat Enterprise Linux Server AUS (v. 6.5)

SRPMS:
libvncserver-0.9.7-7.el6_5.1.src.rpm
    MD5: 27b1dc178e2f9088dfaafab2d40aeb42SHA-256: f7ab1ae67ac02fb3539ce3a971ae99d7e2bd1317fc99e3fc68807733cbc40b15
 
x86_64:
libvncserver-0.9.7-7.el6_5.1.i686.rpm
    MD5: b0b23134cb325ca317e508e671a50eebSHA-256: fe831fce1f66553e6334d4d5aa254b1f80962146ded465e5fbdbc243079aaced
libvncserver-0.9.7-7.el6_5.1.x86_64.rpm
    MD5: 9655ed4ebc717b00fa24ac4528a8d796SHA-256: 408a5631808884a47bda260db99d7f9d9c5e8a42d69ac1a480cd7b199b9db388
libvncserver-debuginfo-0.9.7-7.el6_5.1.i686.rpm
    MD5: e724a8945b598f2e0c8deb04e5270bffSHA-256: 22db53e2df1109d43489b19008e6cfe28ea0348a659a9c2beaf51b1ed4ed2377
libvncserver-debuginfo-0.9.7-7.el6_5.1.x86_64.rpm
    MD5: 00ea40cb1020292fca6e61d5bef38d68SHA-256: aa72f7b847391ff143cf1650c914df3f8da1d3223556b7379ad2e9d23042eee8
libvncserver-devel-0.9.7-7.el6_5.1.i686.rpm
    MD5: db3da76f3489a33fcb9880ba42bca717SHA-256: 20f62374ffde145df7d5c268148ecad022f20b6b08c4655035a50d0349f6bc5d
libvncserver-devel-0.9.7-7.el6_5.1.x86_64.rpm
    MD5: a0e20dcb2bbcd5aeccb1b1fa02603d0bSHA-256: 22eb7b851262ceda686a7a0cb1f4b2ddd9603f5aee6a708c4a5e71241ed88317
 
Red Hat Enterprise Linux Server EUS (v. 6.5.z)

SRPMS:
libvncserver-0.9.7-7.el6_5.1.src.rpm
    MD5: 27b1dc178e2f9088dfaafab2d40aeb42SHA-256: f7ab1ae67ac02fb3539ce3a971ae99d7e2bd1317fc99e3fc68807733cbc40b15
 
IA-32:
libvncserver-0.9.7-7.el6_5.1.i686.rpm
    MD5: b0b23134cb325ca317e508e671a50eebSHA-256: fe831fce1f66553e6334d4d5aa254b1f80962146ded465e5fbdbc243079aaced
libvncserver-debuginfo-0.9.7-7.el6_5.1.i686.rpm
    MD5: e724a8945b598f2e0c8deb04e5270bffSHA-256: 22db53e2df1109d43489b19008e6cfe28ea0348a659a9c2beaf51b1ed4ed2377
libvncserver-devel-0.9.7-7.el6_5.1.i686.rpm
    MD5: db3da76f3489a33fcb9880ba42bca717SHA-256: 20f62374ffde145df7d5c268148ecad022f20b6b08c4655035a50d0349f6bc5d
 
PPC:
libvncserver-0.9.7-7.el6_5.1.ppc.rpm
    MD5: b46f23b235ae951a78d25e49f6a9b3deSHA-256: a4d431c9db18dd4dc4aabc0f6bc507eba7cba1f6959c7f3a958691f2687cce0d
libvncserver-0.9.7-7.el6_5.1.ppc64.rpm
    MD5: fdc025ac9cf59b8dbba4653b450293d3SHA-256: 67711a9e155f11990cc7b1a3dfd4901d0b5e3f62fef60ebe0ed0f14fb8cdc641
libvncserver-debuginfo-0.9.7-7.el6_5.1.ppc.rpm
    MD5: 50afe448d3556dc1f75367c650027059SHA-256: 09039459d47bbaead32f18d3506d2c063cf811bc1b55b3e2b7d9c4d2865b366f
libvncserver-debuginfo-0.9.7-7.el6_5.1.ppc64.rpm
    MD5: 41531a88c29d780167fdc771c6feee55SHA-256: 8d8ad5f689a27367ce4292529e4fb68c6fafc4b4ba29eb3cf07b873c3f7f99d7
libvncserver-devel-0.9.7-7.el6_5.1.ppc.rpm
    MD5: e202ac14fd3d7afcf086bff1af2e3569SHA-256: a0b05e0a0252ff6e1113940b395fb0d532d13f9b3bcac1ac343aac0f7de09e33
libvncserver-devel-0.9.7-7.el6_5.1.ppc64.rpm
    MD5: cadef448b28992198030f9068b55496bSHA-256: 143baf502f5006a234e68f0f2aec2f1bc6d32ceb9877b8d43fbf3ea11a32cabe
 
s390x:
libvncserver-0.9.7-7.el6_5.1.s390.rpm
    MD5: e49e3f5036c1f1726e40fbec9b579e88SHA-256: 7c2cc10432346c371dc90e4179a5f2d5c5bdd25a5018a7f0ac01f208b069e59d
libvncserver-0.9.7-7.el6_5.1.s390x.rpm
    MD5: c6387468d83d89161b48562381c6f0afSHA-256: 41556fee5d075e80bb89a4118bfacc02c4d37b2fb52a98313b7ef2c8c81615bd
libvncserver-debuginfo-0.9.7-7.el6_5.1.s390.rpm
    MD5: ec3b0322a84abb063f71ed56460f255dSHA-256: 157c78b9881e590a39a1f2ed051bf0feb0215b72f21c19c98bd5b617cb43a4dc
libvncserver-debuginfo-0.9.7-7.el6_5.1.s390x.rpm
    MD5: f48f874f2d4752214e49951f8d194a90SHA-256: 76cbe408dc7f7a65e0137e164697080be7fce870a90ace6d2bd46e3acc7a1cde
libvncserver-devel-0.9.7-7.el6_5.1.s390.rpm
    MD5: e262668461a3b10cf00cdc8ae421ece0SHA-256: a68f4f434cf9588f7ee96706467a3f5bbeb1f82df955ceda96a9431634a2dbf4
libvncserver-devel-0.9.7-7.el6_5.1.s390x.rpm
    MD5: 03d76bddef33f982a1a8964e1936ac11SHA-256: ba1e1b84f6a0952c55df9b02b541258add68f74c69f8871cb3e36ba9938c4ef9
 
x86_64:
libvncserver-0.9.7-7.el6_5.1.i686.rpm
    MD5: b0b23134cb325ca317e508e671a50eebSHA-256: fe831fce1f66553e6334d4d5aa254b1f80962146ded465e5fbdbc243079aaced
libvncserver-0.9.7-7.el6_5.1.x86_64.rpm
    MD5: 9655ed4ebc717b00fa24ac4528a8d796SHA-256: 408a5631808884a47bda260db99d7f9d9c5e8a42d69ac1a480cd7b199b9db388
libvncserver-debuginfo-0.9.7-7.el6_5.1.i686.rpm
    MD5: e724a8945b598f2e0c8deb04e5270bffSHA-256: 22db53e2df1109d43489b19008e6cfe28ea0348a659a9c2beaf51b1ed4ed2377
libvncserver-debuginfo-0.9.7-7.el6_5.1.x86_64.rpm
    MD5: 00ea40cb1020292fca6e61d5bef38d68SHA-256: aa72f7b847391ff143cf1650c914df3f8da1d3223556b7379ad2e9d23042eee8
libvncserver-devel-0.9.7-7.el6_5.1.i686.rpm
    MD5: db3da76f3489a33fcb9880ba42bca717SHA-256: 20f62374ffde145df7d5c268148ecad022f20b6b08c4655035a50d0349f6bc5d
libvncserver-devel-0.9.7-7.el6_5.1.x86_64.rpm
    MD5: a0e20dcb2bbcd5aeccb1b1fa02603d0bSHA-256: 22eb7b851262ceda686a7a0cb1f4b2ddd9603f5aee6a708c4a5e71241ed88317
 
(The unlinked packages above are only available from the Red Hat Network)
1144287 – CVE-2014-6051 libvncserver: integer overflow flaw, leading to a heap-based buffer overflow in screen size handling1144293 – CVE-2014-6055 libvncserver: server stacked-based buffer overflow flaws in file transfer handling

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from:

Leave a Reply