2015-07 Security Bulletin: NSM Appliance: Apache HTTP server affected by multiple vulnerabilities

Product Affected:These issues can affect any NSM Appliance running a release prior to the fixed release listed below.

Problem:Multiple vulnerabilities in Apache HTTPD have been addressed by upgrading the Apache HTTPD package to NSM Upgrade Package v4. The following is a list of vulnerabilities that may pose a risk to NSM:CVECVSS v2 base scoreSummaryCVE-2014-0226 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P) Denial of service and potential code execution vulnerability in the Apache mod_status module. CVE-2013-1862 5.1 (AV:N/AC:H/Au:N/C:P/I:P/A:P) Remote command execution vulnerability in the Apache mod_rewrite module. CVE-2013-6438 5.0 (AV:N/AC:L/Au:N/C:N/I:N/A:P) Denial of service (daemon crash) vulnerability in the Apache mod_dav module. CVE-2014-0098 5.0 (AV:N/AC:L/Au:N/C:N/I:N/A:P) Denial of service vulnerability in the Apache mod_log_config module. CVE-2014-0231 5.0 (AV:N/AC:L/Au:N/C:N/I:N/A:P) Denial of service (process hang) vulnerability in the Apache mod_cgid module. CVE-2012-3499 4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N) Multiple cross-site scripting (XSS) vulnerabilities in the Apache HTTP Server. CVE-2012-4558 4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N) Multiple cross-site scripting (XSS) vulnerabilities in the Apache mod_proxy_balancer module. CVE-2013-1896 4.3 (AV:N/AC:M/Au:N/C:N/I:N/A:P) Denial of service vulnerability in the Apache mod_dav_svn module. CVE-2014-0118 4.3 (AV:N/AC:M/Au:N/C:N/I:N/A:P) Denial of service vulnerability in the Apache mod_deflate module. CVE-2008-0456 2.6 (AV:N/AC:H/Au:N/C:N/I:P/A:N) CRLF injection vulnerability in the Apache mod_negotiation module. CVE-2012-2687 2.6 (AV:N/AC:H/Au:N/C:N/I:P/A:N) Multiple cross-site scripting (XSS) vulnerabilities in the Apache mod_negotiation module. Juniper SIRT is not aware of any malicious exploitation of these vulnerabilities against NSM Appliance.

Solution:NSM online or offline Upgrade Package v4 includes the resolved version of Apache HTTP server. Additionally, NSM 2012.2R9 and all subsequent releases also contain the fix. These issues are being tracked as PR 10176693 and is visible on the Customer Support website. KB16765 – “In which releases are vulnerabilities fixed?” describes which release vulnerabilities are fixed as per our End of Engineering and End of Life support policies.

Workaround:Use access lists or firewall filters to limit access to the web interface of the NSM Appliance only from trusted hosts.

Implementation:How to obtain fixed software: NSM Maintenance Releases are available at http://support.juniper.net from the “Download Software” links. If a Maintenance Release is not adequate and access to NSM patches is needed, open a customer support case. A JTAC engineer will review your request and respond, ensuring that you will be provided with the most appropriate Patch Release for your specific situation. Modification History: 2015-07-08: Initial publication

Related Links: CVSS Score:CVSSv2: 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P)

Risk Level:Medium

Risk Assessment:Information for how Juniper Networks uses CVSS can be found at KB 16446 “Common Vulnerability Scoring System (CVSS) and Juniper’s Security Advisories.”

Acknowledgements: 

Leave a Reply