Red Hat OpenShift Enterprise release 2.2.6 is now available with updates topackages that fix several bugs and introduce feature enhancements.

OpenShift Enterprise by Red Hat is the company’s cloud computingPlatform-as-a-Service (PaaS) solution designed for on-premise or private clouddeployments.Space precludes documenting all of the bug fixes in this advisory. See theOpenShift Enterprise Technical Notes, which will be updated shortly for release2.2.6, for details about these changes:https://access.redhat.com/documentation/en-US/OpenShift_Enterprise/2/html-single/Technical_Notes/index.htmlAll OpenShift Enterprise 2 users are advised to upgrade to these updatedpackages.
Red Hat OpenShift Enterprise 2

SRPMS:
openshift-enterprise-upgrade-2.2.6-1.el6op.src.rpm
    MD5: d15d51acf7a97fc280baf06ac7763656SHA-256: e80c62fc2515e8655d2a770ba4d3d5431d23e4db2faaa1262da9ae406510db1a
openshift-origin-broker-1.16.2.8-1.el6op.src.rpm
    MD5: 46d9f1ab9aa2cb9f5df42097fcf72c04SHA-256: 5a8529499179b8a24c870b980ca57abf910b45e618718c4559f0f1d771c46f18
openshift-origin-broker-util-1.35.2.4-1.el6op.src.rpm
    MD5: 65480ae64805d9664abde6ad29dedc5eSHA-256: 7b32640e57ad102815243f97698859481ed68db2ec343fabfd603abadc135755
openshift-origin-cartridge-php-1.33.1.1-1.el6op.src.rpm
    MD5: 01a14397d8f231bfcfd132f3d98adf61SHA-256: d28cc7d93802711ba0c179978ef9640a837fa2a166432d667af7c1a39304c66c
openshift-origin-console-1.16.3.6-1.el6op.src.rpm
    MD5: f2bd3a1e9afaf12e18af192b87621103SHA-256: a72b9b503a4ab0fd9957946ae79d74a0b2776a90693c48a376900b7adb29a368
openshift-origin-logshifter-1.9.1.1-1.el6op.src.rpm
    MD5: cf26da889f2548d78cac5463df030179SHA-256: a81390523c44a083497bd086ebc97c512325e77e4efe64e06aa1d8a4b86d4705
openshift-origin-node-util-1.36.1.1-1.el6op.src.rpm
    MD5: d1c9cbb5c4cb3548ced93c837778565aSHA-256: 1212861719565851b64efbedf148aafe87274eb4650f29816164f7d265c00e14
rhc-1.36.1.1-1.el6op.src.rpm
    MD5: eee902d67c1602825944130d07fd631dSHA-256: dafe406feaabf0f1038bd38d91dcdedec910aeeade1ee474c941a9f61c7d0956
rsyslog7-7.4.10-4.el6op.src.rpm
    MD5: d3c34861fd4cc1b36d90dc3a265f348dSHA-256: 00c36354840cde2101edb9a975884ad1c8e902974738e8553bbd2b40a991461c
ruby193-rubygem-passenger-3.0.21-4.el6op.src.rpm
    MD5: 8be15f87aaafc46229ecc8df660114faSHA-256: 79520d7ad957f892fb6e37fe0a81a04fd1a601ae08bd4ca179d4190717316efe
rubygem-openshift-origin-console-1.34.1.2-1.el6op.src.rpm
    MD5: 530e69a8a0b937bea343d3e848e9ed21SHA-256: c76c9943ffb4a61c778dfd887bcd23c5b3e2b4549fd0a228c9d57f8f7523521d
rubygem-openshift-origin-container-selinux-0.10.1.1-1.el6op.src.rpm
    MD5: c1649ab5fbf1abcb85e7f3b01425fcbbSHA-256: 68da116bd8d91f33dc5fa6a088610ac9bad8467b73dfb7a77d909ca92719b0e8
rubygem-openshift-origin-controller-1.36.2.3-1.el6op.src.rpm
    MD5: 44ca993b3c4fa516674cb093e70cce84SHA-256: 58a347fa032a26737ea28c59a46f4c47799c5714dfffcaf0bdb7bf7b6684106d
rubygem-openshift-origin-msg-broker-mcollective-1.34.1.1-1.el6op.src.rpm
    MD5: ef956d8c5a4746700a308d3b51cbccb7SHA-256: cbd26a451b237d2967d77bc6418194c93bd22813d08a6fd85ad54e4aa2a13003
rubygem-openshift-origin-node-1.36.2.2-1.el6op.src.rpm
    MD5: 678c2a5728bfec45478bbc84575ba144SHA-256: 3b6177ea8fd64490f7cfd71be9e521372933812ff40ff8034bebf59ff5f3bf91
rubygem-openshift-origin-routing-daemon-0.24.1.1-1.el6op.src.rpm
    MD5: b2f67fc6bee3ebf5e46365063f2974aaSHA-256: e9a9adabc31dbec4b1e5f0f573873f1bb69323ea7ca2e4ec8bfa754548a09fe7
rubygem-openshift-origin-sso-activemq-0.0.1.1-1.el6op.src.rpm
    MD5: c4394d688844d00136394e4685f9ef74SHA-256: f64ebe480b94f5c165622608607108050a70084014ee83c2022c2aadcf9e4939
 
x86_64:
openshift-enterprise-release-2.2.6-1.el6op.noarch.rpm
    MD5: 41bcf95f1d543c91f9ae4e11be403a27SHA-256: 740a2b94398ccbad630994228448f61a51d9a7e208005501db1189032e3e0701
openshift-enterprise-upgrade-broker-2.2.6-1.el6op.noarch.rpm
    MD5: ad9d3040726d9af55d8d50ce4c882443SHA-256: 41c1a07f97cb8a15482985a3cd06f8d9b0365dee3e225935312636a4552b2b0c
openshift-enterprise-upgrade-node-2.2.6-1.el6op.noarch.rpm
    MD5: 45de1dd54202aff609ca223e0a7a53f2SHA-256: ee2e56d702e9201074e3b5a6c9e96fe58d1f6db53c6441e0f2f14a90357cecae
openshift-enterprise-yum-validator-2.2.6-1.el6op.noarch.rpm
    MD5: ee6ecb801142a9a9a846030d1f5a930eSHA-256: 8bcf350e9d0492ed0dcbbbdd3ed2ac27af8d6ece8e42995f1a5ab1ae3527c6cb
openshift-origin-broker-1.16.2.8-1.el6op.noarch.rpm
    MD5: aebbc27cc88f3e63332a90074458f8e7SHA-256: a5a9dd06d6a4c513fc3cea0027953dee6cb3c0e8359da8c1811db6d19ff75573
openshift-origin-broker-util-1.35.2.4-1.el6op.noarch.rpm
    MD5: bfc67f095b5174e55b6e72e73712f7dcSHA-256: 582c23d5f70aac48b7a52aede83f7569199e9aa55e39c49567f21104a57f33d4
openshift-origin-cartridge-php-1.33.1.1-1.el6op.noarch.rpm
    MD5: a4f30d6a5f431694f4b576fabb0708f4SHA-256: d5a2545cf3188e2326bf2f90dc1c1365eafe538d7415f43747f36e863502077a
openshift-origin-console-1.16.3.6-1.el6op.noarch.rpm
    MD5: 27ee4a6af6fd20e927538f76d59ba0dcSHA-256: 81bc870b516a4312850e8b18f15d8de90d54035eb5eec25b4ff1176fa30be14e
openshift-origin-logshifter-1.9.1.1-1.el6op.x86_64.rpm
    MD5: c96bde3d9918c67ba3393c7b70dbb33dSHA-256: 0764e1ab46b5c1f5f85cb7b14c52b8e8ac3467281ce9b4895d1a1147637e8b29
openshift-origin-node-util-1.36.1.1-1.el6op.noarch.rpm
    MD5: b4ee717da6ace8418e1839da1297aeaaSHA-256: a9a382c94a1f1aead5c0735fa0e9b39bc1e7ef209d580999aac7427c6f2a11d9
rhc-1.36.1.1-1.el6op.noarch.rpm
    MD5: 0bdb95a2516888140a179c296f262fadSHA-256: 0f4c66234815815e43f9120af4633742704727c2bb92a874920469b98ff6f0a8
rsyslog7-mmopenshift-7.4.10-4.el6op.x86_64.rpm
    MD5: 2c2c3af677e847ec8aa2246f04369f29SHA-256: bfbe9c0fa2d081475f68479ec0f416d73e85159a37478490ef88462bbd7bc359
ruby193-mod_passenger-3.0.21-4.el6op.x86_64.rpm
    MD5: 4320425dfeb1cb9d5bdf5a0650d8da19SHA-256: f5a6514f3b76e8e6d5bb11ccf6cdd114ce6a73bec35fe0ec8c03d739540dfbaf
ruby193-rubygem-passenger-3.0.21-4.el6op.x86_64.rpm
    MD5: 6178ddc42803db6a46d722c101b26c61SHA-256: 05db917c7608b1c1dbc547662449b253e69b047081ff4fa42df21b0c8180a92d
ruby193-rubygem-passenger-devel-3.0.21-4.el6op.x86_64.rpm
    MD5: 77a57cb5112a84f439bc0dd73621c797SHA-256: cc40e5d3e6569ab003c86a8d27893c3263b8b99f7d2ecd44d560cd4ce79aa250
ruby193-rubygem-passenger-native-3.0.21-4.el6op.x86_64.rpm
    MD5: c18ed3e343d43d4c7ad283ef34b7b058SHA-256: 91c39b35e51370a4448bd57e2ae937ad1a104c7bc22e1bf41ab1c65e38e2cf50
ruby193-rubygem-passenger-native-libs-3.0.21-4.el6op.x86_64.rpm
    MD5: 169cee7a05d3ba256ac2f55cde339aa4SHA-256: 8b12ff94278e6298c441a3f14f530041ebd85a94b1b8f078f057b7a5569f38f6
rubygem-openshift-origin-console-1.34.1.2-1.el6op.noarch.rpm
    MD5: 9499571810c2f9f63301a65102b9fbd7SHA-256: 8e0d0f31a5c47e5cb5e758104b8e286e324107cf8dde33173f86b0b569114442
rubygem-openshift-origin-container-selinux-0.10.1.1-1.el6op.noarch.rpm
    MD5: 6602bd25d4ba37a091e8760b9e9ba90fSHA-256: 535b978d41c8dc77e0ec9a8b953d7386ae5ba7fbf6751f41f1d24a57c637606e
rubygem-openshift-origin-controller-1.36.2.3-1.el6op.noarch.rpm
    MD5: eab72c3f9841f00eefe03968cb66d399SHA-256: e780ebbbdfb815c5050d60fb3661085c4f46dc55f61734c707b7dbde685a0f86
rubygem-openshift-origin-msg-broker-mcollective-1.34.1.1-1.el6op.noarch.rpm
    MD5: c9dc0b98bfb460386f98a0747733cf11SHA-256: 1fdffda9455d0413fb3b88dc17748ce7e4efc00273cb18551f280955f58d5f4f
rubygem-openshift-origin-node-1.36.2.2-1.el6op.noarch.rpm
    MD5: 5a8630c2d6acc0d73a786c76de9687a7SHA-256: d5bc688431ae6ff693119858575ff9893fa48fdf64bed60273599357f1e3b6d9
rubygem-openshift-origin-routing-daemon-0.24.1.1-1.el6op.noarch.rpm
    MD5: 0b98a488c5b4239c45462792a7725f08SHA-256: 042c7865861bfa83b9bfde3eade211e206a0294cbd51c34130696111f6739075
rubygem-openshift-origin-sso-activemq-0.0.1.1-1.el6op.noarch.rpm
    MD5: c40e91a328456de6490e0241b4d1c90cSHA-256: 245f30fb5979d9cf8e793a7a5572eb57ac501517abdc091ef1501306737b889a
 
(The unlinked packages above are only available from the Red Hat Network)
1094454 – [RFE] Memcached should be able to be used as the cache store for the broker and console1145344 – [RFE] oo-admin-clt-domain should be able to manage domain menbership1172055 – Can not install dependency by composer in php gear due to missing ‘$OPENSHIFT_PHP_DIR/usr/bin’ in $OPENSHIFT_PHP_PATH_ELEMENT after upgrade from OSE 2.1->2.21191238 – oo-admin-ctl-app does not accept a ‘namespace’ option1200123 – [RFE] Integration with external SSO1202705 – rsyslog mmopenshift does not log namespace in scaled gears1207300 – enhance oo-admin-ctl-cartridge to display IDs (OIDs) with cartridge details1210489 – Enable-HA registers routing appliaction DNS twice, breaking functionality for some custom DNS plugins1212020 – routing daemon can not delete monitor due to improper configuration usage.1212583 – Ruby app trys to load module and connection is refused1214832 – openshift-tc fails at boot time if node uses a bonded NIC due to init script priority1216220 – oo-snapshot is not working1216223 – OSE 2.2 – Allow oo-admin-yum-validator to setup a node for EAP 6.4 channels.1217587 – oo-admin-ctl-district command’s district argument requirement is unnecessary1217588 – pass multiple gears to oo-admin-move and provide final output in json1218049 – Failed to repair the HA app with the head gear located on the unresponsive node1221786 – [RFE] Provide a way for users to set a usage_account_id in the database1222953 – Logshifter configuration parsing stops at a new line

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from:

Leave a Reply