A vulnerability in a user script supplied with Cisco Firepower 9000 devices could allow an authenticated, remote attacker to view any file on the device, even ones that should be restricted to authenticated users.
 
The vulnerability is due to lack of input validation of the parameters passed to certain user scripts. An attacker could exploit this vulnerability by authenticating to the device and crafting user input to certain script files to view files that should be restricted.

Cisco has not released software updates that address this vulnerability. Workarounds that mitigate this vulnerability are not available.

This advisory is available at the following link: http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20151117-firepower1

Leave a Reply