A vulnerability in a user script supplied with Cisco Firepower 9000 could allow an authenticated, remote attacker to execute arbitrary commands on the underlying operating system with the privileges of the authenticated user. The script can be accessed via the web interface.
 
The vulnerability is due to lack of input validation of the parameters passed to the user script. An attacker could exploit this vulnerability by authenticating to the device and crafting user input to specific script files to inject arbitrary commands. These commands are at the privilege level of the authenticated user.

Cisco has not released software updates that address this vulnerability. There are no workarounds that address this vulnerability.

This advisory is available at the following link: http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20151123-fire

Leave a Reply