Updated redis packages that fix a security issue are now available forRed Hat Enterprise Linux OpenStack Platform 6.0.Red Hat Product Security has rated this update as having Moderate securityimpact. A Common Vulnerability Scoring System (CVSS) base score, whichgives a detailed severity rating, is available from the CVE link in theReferences section.

Redis is an advanced key-value store. It is often referred to as a data structure server because keys can contain strings, hashes, lists, sets, orsorted sets.An integer-wraparound flaw leading to a stack-based overflow was found inRedis. A user with access to run Lua code in a Redis session could possiblyuse this flaw to crash the server (denial of service) or gain codeexecution outside of the Lua sandbox. (CVE-2015-8080)All users of redis are advised to upgrade to these updated packages, whichcorrect this issue.
Before applying this update, make sure all previously released erratarelevant to your system have been applied.For details on how to apply this update, refer to:https://access.redhat.com/articles/11258
1278965 – CVE-2015-8080 redis: Integer wraparound in lua_struct.c causing stack-based buffer overflow

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from: