An update for openvswitch is now available for Red Hat Enterprise LinuxOpenStack Platform 6.0 (Juno) for RHEL 7.Red Hat Product Security has rated this update as having a security impact ofImportant.

A Common Vulnerability Scoring System (CVSS) base score, which givesa detailed severity rating, is available for each vulnerability from the CVElink(s) in the References section.
Open vSwitch provides standard network bridging functions and support for theOpenFlow protocol for remote per-flow control of traffic.Security Fix(es):* A buffer overflow flaw was discovered in the OVS processing of MPLS labels.

Aremote attacker able to deliver a frame containing a malicious MPLS label thatwould be processed by OVS could trigger the flaw and use the resulting memorycorruption to cause a denial of service (DoS) or, possibly, execute arbitrarycode. (CVE-2016-2074)Red Hat would like to thank the Open vSwitch project for reporting this issue.Upstream acknowledges Kashyap Thimmaraju and Bhargava Shastry as the originalreporters.
Red Hat OpenStack 6.0 for RHEL 7

SRPMS:
openvswitch-2.4.0-2.el7_2.src.rpm
    MD5: 25a8aaf9ce85a584f93b150f56471faaSHA-256: 019ae1e06f250bfe9b644e4a8c083f90a29f27721f04449631cb0767162eec41
 
x86_64:
openvswitch-2.4.0-2.el7_2.x86_64.rpm
    MD5: e6b6a8277bcc49e2ae5e8af64f429df9SHA-256: 3d5797c92afce3b63b940ff2f2031beaeaa37893aad79c0fffe4ffcf776aa70d
openvswitch-debuginfo-2.4.0-2.el7_2.x86_64.rpm
    MD5: c1f4d1e133b261adde99dbf21a30826eSHA-256: bf00521083eec34244e290aa05d120afb5918163fa2c39a62170483fedbe508d
python-openvswitch-2.4.0-2.el7_2.noarch.rpm
    MD5: 99c4730e0606948592fa4d3292ebb4f8SHA-256: bca526efd9b4c64cee767cf11e9407673baa7e34c06b14bc834bfa6ff7413d4e
 
(The unlinked packages above are only available from the Red Hat Network)

1318553 – CVE-2016-2074 openvswitch: MPLS buffer overflow vulnerability

These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from: