Updated rh-nodejs4 packages that fix one bug are now available for Red HatSoftware Collections.
Node.js is a software development platform for building fast and scalablenetwork applications in the JavaScript programming language.This update fixes the following bug:* The rh-nodejs4 Software Collection previously contained an outdated packagerh-nodejs4-nodejs-tunnel-agent.

Consequently, users were unable to use thisSoftware Collection or its associated S2I image from behind an HTTP proxy.

Therh-nodejs4-nodejs-tunnel-agent package has been updated to the latest version,and the rh-nodejs4 Software Collection and the associated S2I image are nowfully usable. (BZ#1366491)Users of rh-nodejs4 are advised to upgrade to these updated packages, which fixthis bug.
Before applying this update, make sure all previously released erratarelevant to your system have been applied.For details on how to apply this update, refer to:https://access.redhat.com/articles/11258Red Hat Software Collections 1 for RHEL 6

SRPMS:
rh-nodejs4-nodejs-tunnel-agent-0.4.3-1.el6.src.rpm
    MD5: 71af3bcc05e8ade385fc475c28bae278SHA-256: 7e82fb1b3af4f7c5c1774e3a8a872184c0c0986bdaa9d26f42bb938e8348c343
 
x86_64:
rh-nodejs4-nodejs-tunnel-agent-0.4.3-1.el6.noarch.rpm
    MD5: e84571d06b0dc4b634ef12e993254c3cSHA-256: 58767d7b527374f822abeb1267cff32f194c1e5b92d39b046f208d32aad165c4
 
Red Hat Software Collections 1 for RHEL 7

SRPMS:
rh-nodejs4-nodejs-tunnel-agent-0.4.3-1.el7.src.rpm
    MD5: 8eeb0873708b892c20e1ff7441debe8eSHA-256: 6803dd4ea789fb0bb62a26b2f19a0099f0b803b75ce3f8e70c39c1f9bd0353ea
 
x86_64:
rh-nodejs4-nodejs-tunnel-agent-0.4.3-1.el7.noarch.rpm
    MD5: 197be71110c7b76fb0fe28a9540dbb11SHA-256: f697b81ae9d3bf8dcfed38340bf0f488b1ef0fdea8c64ea8398f06f6f3f1f42d
 
(The unlinked packages above are only available from the Red Hat Network)

1366491 – nodejs-4-rhel7 image cannot work behind http proxy

These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:

Leave a Reply