Vulnerability Note VU#346175
Imagely NextGen Gallery plugin for WordPress contains a local file inclusion vulnerability
Original Release date: 16 Nov 2016 | Last revised: 16 Nov 2016

Overview
The Imagely NextGen Gallery plugin for WordPress prior to version 2.1.57 may execute code from an uploaded malicious file.

Description
CWE-98: Improper Control of Filename for Include/Require Statement in PHP Program (‘PHP Remote File Inclusion’) – CVE-2016-6565
The Imagely NextGen Gallery plugin for WordPress prior to version 2.1.57 does not properly validate user input in the cssfile parameter of a HTTP POST request, which may allow an authenticated user to read arbitrary files from the server, or execute arbitrary code on the server in some circumstances (dependent on server configuration).

Impact
An authenticated user may be able to read arbitrary files on the server or execute code on the server by including a malicious local file in a formatted server request.

Solution
Apply an update

Imagely has released the NextGen Gallery plugin version 2.1.57 to address this issue.

Affected users are encouraged to upgrade to version 2.1.57 or later as soon as possible.

Vendor Information (Learn More)

VendorStatusDate NotifiedDate UpdatedImagelyAffected12 Oct 201614 Nov 2016If you are a vendor and your product is affected, let
us know.

CVSS Metrics (Learn More)

Group
Score
Vector

Base
9.0
AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal
7.0
E:POC/RL:OF/RC:C

Environmental
5.3
CDP:ND/TD:M/CR:ND/IR:ND/AR:ND

References

https://wordpress.org/plugins/nextgen-gallery/
http://cwe.mitre.org/data/definitions/98.html

Credit

Thanks to Mukhammad Khalilov for reporting this vulnerability.
This document was written by Garret Wassermann.

Other Information

CVE IDs:
CVE-2016-6565

Date Public:
15 Nov 2016

Date First Published:
16 Nov 2016

Date Last Updated:
16 Nov 2016

Document Revision:
24

FeedbackIf you have feedback, comments, or additional information about this vulnerability, please send us email.

Leave a Reply