A vulnerability in the implementation of X.509 Version 3 for SSH authentication functionality in Cisco IOS and IOS XE Software could allow an unauthenticated, remote attacker to bypass authentication on an affected system.

The vulnerability is due to improper validation of X.509 signatures during the SSH authentication phase.

An attacker could exploit this vulnerability by presenting an invalid X.509 signature to an affected system.

A successful exploit could allow the attacker to impersonate an existing valid user over an SSH connection.

There are no workarounds that address this vulnerability.

This advisory is available at the following link:
http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20161207-ios-xe-x509
A vulnerability in the implementation of X.509 Version 3 for SSH authentication functionality in Cisco IOS and IOS XE Software could allow an unauthenticated, remote attacker to bypass authentication on an affected system.

The vulnerability is due to improper validation of X.509 signatures during the SSH authentication phase.

An attacker could exploit this vulnerability by presenting an invalid X.509 signature to an affected system.

A successful exploit could allow the attacker to impersonate an existing valid user over an SSH connection.

There are no workarounds that address this vulnerability.

This advisory is available at the following link:
http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20161207-ios-xe-x509

Security Impact Rating: Medium

CVE: CVE-2016-6474

Leave a Reply