An update for flash-plugin is now available for Red Hat Enterprise Linux 6Supplementary.Red Hat Product Security has rated this update as having a security impact ofCritical.

A Common Vulnerability Scoring System (CVSS) base score, which gives adetailed severity rating, is available for each vulnerability from the CVElink(s) in the References section.
The flash-plugin package contains a Mozilla Firefox compatible Adobe FlashPlayer web browser plug-in.This update upgrades Flash Player to version 24.0.0.194.Security Fix(es):* This update fixes multiple vulnerabilities in Adobe Flash Player.

Thesevulnerabilities, detailed in the Adobe Security Bulletin listed in theReferences section, could allow an attacker to create a specially crafted SWFfile that would cause flash-plugin to crash, execute arbitrary code, or disclosesensitive information when the victim loaded a page containing the malicious SWFcontent. (CVE-2017-2925, CVE-2017-2926, CVE-2017-2927, CVE-2017-2928,CVE-2017-2930, CVE-2017-2931, CVE-2017-2932, CVE-2017-2933, CVE-2017-2934,CVE-2017-2935, CVE-2017-2936, CVE-2017-2937, CVE-2017-2938)
Red Hat Enterprise Linux Desktop Supplementary (v. 6)

IA-32:
flash-plugin-24.0.0.194-1.el6_8.i686.rpm
    MD5: 89b0f146cac8ceb7cdf0d34c671dbf8dSHA-256: c791905f5cac7148af679887190c481616d2241f559f726f00238772fec1bc16
 
x86_64:
flash-plugin-24.0.0.194-1.el6_8.i686.rpm
    MD5: 89b0f146cac8ceb7cdf0d34c671dbf8dSHA-256: c791905f5cac7148af679887190c481616d2241f559f726f00238772fec1bc16
 
Red Hat Enterprise Linux Server Supplementary (v. 6)

IA-32:
flash-plugin-24.0.0.194-1.el6_8.i686.rpm
    MD5: 89b0f146cac8ceb7cdf0d34c671dbf8dSHA-256: c791905f5cac7148af679887190c481616d2241f559f726f00238772fec1bc16
 
x86_64:
flash-plugin-24.0.0.194-1.el6_8.i686.rpm
    MD5: 89b0f146cac8ceb7cdf0d34c671dbf8dSHA-256: c791905f5cac7148af679887190c481616d2241f559f726f00238772fec1bc16
 
Red Hat Enterprise Linux Workstation Supplementary (v. 6)

IA-32:
flash-plugin-24.0.0.194-1.el6_8.i686.rpm
    MD5: 89b0f146cac8ceb7cdf0d34c671dbf8dSHA-256: c791905f5cac7148af679887190c481616d2241f559f726f00238772fec1bc16
 
x86_64:
flash-plugin-24.0.0.194-1.el6_8.i686.rpm
    MD5: 89b0f146cac8ceb7cdf0d34c671dbf8dSHA-256: c791905f5cac7148af679887190c481616d2241f559f726f00238772fec1bc16
 
(The unlinked packages above are only available from the Red Hat Network)

1411929 – CVE-2017-2925 CVE-2017-2926 CVE-2017-2927 CVE-2017-2928 CVE-2017-2930 CVE-2017-2931 CVE-2017-2932 CVE-2017-2933 CVE-2017-2934 CVE-2017-2935 CVE-2017-2936 CVE-2017-2937 CVE-2017-2938 flash-plugin: multiple code execution issues fixed in APSB17-02

These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:

Leave a Reply