Cross-site scripting, request forgery, and more!
WordPress has patched a series of vulnerabilities in its content management system shuttering bugs affecting more than 10 million users.
The release of version 4.7.1 closes eight vulnerabilities including cross-site scripting, cross-site request forgery, and other remotely-acessible attack vectors.

“This is a security release for all previous versions and we strongly encourage you to update your sites immediately,” WordPress security bods say.
The CMS crew says version 4.7 which bears the bugs has been downloaded some 10 million times since its 6 December release, however those vulnerabilities are likely to also affect earlier versions.
The vulnerabilities include possible remote code execution in PHPMailer which is not known to affect WordPress directly and is updated to squish the reported bug out of caution.
A flaw with REST API exposed user data for all users who had authored a post of a public post type, WordPress types say.
Two cross-site scripting holes were found, one through the plugin name or version header on update-core.php, and another via theme name fallback.
Uploading a Flash file creates opportunities for cross-site request forgery bypasses in unpatched systems, WordPress says, as does the accessibility mode of widget editing.
Weak cryptographic security for multisite activation keys was also squished.
WordPress is the world’s most popular content management system with some 140 million downloads. ®
Sponsored: Flash enters the mainstream. Visit The Register’s storage hub

Leave a Reply