An update for ansible is now available for Red Hat OpenStack Platform 10.0(Newton).Red Hat Product Security has rated this update as having a security impact ofImportant.

A Common Vulnerability Scoring System (CVSS) base score, which givesa detailed severity rating, is available for each vulnerability from the CVElink(s) in the References section.
Ansible is a radically simple model-driven configuration management, multi-nodedeployment, and remote task execution system.

Ansible works over SSH and doesnot require any software or daemons to be installed on remote nodes.

Extensionmodules can be written in any language and are transferred to managed machinesautomatically.The following packages have been upgraded to a newer upstream version: ansible(2.2.1.0). (BZ#1412370)Security Fix(es):* An input validation vulnerability was found in Ansible’s handling of data sentfrom client systems.

An attacker with control over a client system being managedby Ansible and the ability to send facts back to the Ansible server could usethis flaw to execute arbitrary code on the Ansible server using theAnsible-server privileges. (CVE-2016-9587)

1404378 – CVE-2016-9587 Ansible: Compromised remote hosts can lead to running commands on the Ansible controller

These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:

Leave a Reply