A vulnerability in Common Internet Filesystem (CIFS) code in the
Clientless SSL VPN functionality of Cisco ASA Software could allow an
authenticated, remote attacker to cause a heap overflow.

The
vulnerability is due to insufficient validation of user supplied input.

An attacker could
exploit this vulnerability by sending a crafted URL to the affected
system.

An exploit could allow the remote attacker to cause a reload of the
affected system or potentially execute code.

Note:
Only traffic directed to the affected system can
be used to exploit this vulnerability.

This vulnerability affects
systems configured in routed firewall mode only and in single or
multiple context mode.

This vulnerability can be triggered by IPv4 or
IPv6 traffic.

A valid TCP connection is needed to perform the attack.

The attacker needs to have valid credentials to log in to the Clientless SSL VPN portal.

Cisco has released software updates that address this vulnerability. Workarounds that mitigate this vulnerability are available.
This advisory is available at the following link:
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20170208-asa
A vulnerability in Common Internet Filesystem (CIFS) code in the
Clientless SSL VPN functionality of Cisco ASA Software could allow an
authenticated, remote attacker to cause a heap overflow.

The
vulnerability is due to insufficient validation of user supplied input.

An attacker could
exploit this vulnerability by sending a crafted URL to the affected
system.

An exploit could allow the remote attacker to cause a reload of the
affected system or potentially execute code.

Note:
Only traffic directed to the affected system can
be used to exploit this vulnerability.

This vulnerability affects
systems configured in routed firewall mode only and in single or
multiple context mode.

This vulnerability can be triggered by IPv4 or
IPv6 traffic.

A valid TCP connection is needed to perform the attack.

The attacker needs to have valid credentials to log in to the Clientless SSL VPN portal.

Cisco has released software updates that address this vulnerability. Workarounds that mitigate this vulnerability are available.
This advisory is available at the following link:
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20170208-asa

Security Impact Rating: High

CVE: CVE-2017-3807

Leave a Reply