A vulnerability in certain system script files that are installed at boot time on Cisconbsp;Application Policy Infrastructure Controllers could allow an authenticated, local attacker to gain elevated privileges and execute arbitrary commands with root privileges on an affected host operating system.

The vulnerability is due to insufficient validation of user-controlled input that is supplied to certain script files of an affected system.

An attacker could exploit this vulnerability by submitting crafted input to a script file on an affected system.

A successful exploit could allow the attacker to gain elevated privileges and execute arbitrary commands with root privileges on the affected system. To exploit this vulnerability, the attacker would need to authenticate to the affected system by using valid administrator credentials.

There are no workarounds that address this vulnerability.

This advisory is available at the following link:
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20171129-apic

Security Impact Rating: Medium

CVE: CVE-2017-12352

Leave a Reply