A vulnerability in Cisconbsp;NX-OS System Software running on Cisconbsp;MDS Multilayer Director Switches, Cisconbsp;Nexus 7000 Series Switches, and Cisconbsp;Nexus 7700 Series Switches could allow an authenticated, local attacker to access the Bash shell of an affected device’s operating system, even if the Bash shell is disabled on the system.

The vulnerability is due to insufficient sanitization of user-supplied parameters that are passed to certain functions of the Python scripting sandbox of the affected system.

An attacker could exploit this vulnerability to escape the scripting sandbox and enter the Bash shell of the operating system with the privileges of the authenticated user for the affected system.

To exploit this vulnerability, the attacker must have local access to the affected system and be authenticated to the affected system with administrative or Python execution privileges.

There are no workarounds that address this vulnerability.

This advisory is available at the following link:
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20171129-switch

Security Impact Rating: Medium

CVE: CVE-2017-12340

Leave a Reply