A vulnerability in Cisco NX-OS System Software patch installation could allow an authenticated, local attacker to write a file to arbitrary locations.

The vulnerability is due to insufficient restrictions in the patch installation process.

An attacker could exploit this vulnerability by installing a crafted patch image on an affected device.

The vulnerable operation occurs prior to patch activation.

An exploit could allow the attacker to write arbitrary files on an affected system as root.

The attacker would need valid administrator credentials to perform this exploit.

There are no workarounds that address this vulnerability.

This advisory is available at the following link:
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20171129-nxos1

Security Impact Rating: Medium

CVE: CVE-2017-12332

Leave a Reply