A vulnerability in the CLI of Cisco NX-OS System Software could allow an authenticated, local attacker to perform a command injection attack.

An attacker would need valid administrator credentials to perform this exploit.

The vulnerability is due to insufficient input validation during the installation of a software patch.

An attacker could exploit this vulnerability by installing a crafted patch image with the vulnerable operation occurring prior to patch activation.

An exploit could allow the attacker to execute arbitrary commands on an affected system as root.

There are no workarounds that address this vulnerability.

This advisory is available at the following link:
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20171129-nxos8

Security Impact Rating: Medium

CVE: CVE-2017-12341

Leave a Reply